Cannot Get Inform To Work Properly

I’m on macOS Sierra 10.12.4
Inform version 1.64 (1.64.1)
I tried making a simple inform game.
If I enter: The bedroom is a room.
Everything looks fine. Results are good.
But, when hit GO and try to play the game in the Story tab, there is nothing there, it’s blank, and I cannot type anything.
I tried loading a sample story, and the same thing happens. Blank. Nothing.
I’ve been going nutso trying to figure out what’s going on.
I finally tried changing the default Story File Format setting from Glulx to Z-Code and now it seems to work.
Why is Glulx the default setting if it doesn’t work properly?
Furthermore, what if I want to use the Glulx format, how can I get it to work?
It says that it’s the “most capable” of the two formats and is the default setting, so I feel that I should use that setting.
Anyone have a solution?



(I spoiler-tagged your images because they were very large and were making the forum display weirdly.)

The built-in Glulx interpreter (that is, the thing that runs the story in that pane) in the Macintosh IDE that you can get on the official Inform website doesn’t work in Sierra. If you go here you can find a download for the Inform app that should work in Sierra.

Awesome, thanks.
It works!

I just found a related post with someone with the same problem who solved it in the same way:

Yeah, it’s a pretty common issue given that the download on the official site doesn’t work with the must current operating system. We’ve been talking about some ways that we could maybe try to make this not happen so much (where “we” doesn’t mean the people who run the Inform site, unfortunately).

And now the fixed version is on the the official Inform site, hooray!

Hallelujah! Thanks to Inform team :slight_smile:

I’m particularly grateful because I mentioned this issue very reluctantly the other night in the comments on Emily’s recent blog post about Inform’s status …