Blighted Isle, possible bug/hint request

Hi All,

I’ve begun playing Eric Eve’s lovely Blighted Isle recently, and have encountered what is at least a poorly implemented sequence, if not a definite bug. It seems to be stalling progress, so I’d appreciate some guidance.

I’m with Julia in the northern part of the island. I’m trying to fix the bridge which crosses the stream so I can explore further. The built-in hints suggest that I should look on the wooded slope which is a couple rooms away. This seems logical to me, and I’d have done so anyway, but I’m constantly told there’s nothing of use there whenever I try. “search wood,” and similar phrasings don’t find anything. I feel like I’m playing guess the noun, which isn’t fair.

Thanks for any input,

As an update, I’ve been in contact with Eric Eve, and he tells me the bugs I’m experiencing are caused by some Tads 3 library changes he wasn’t aware of. I’m pleased to know that I wasn’t barking up the wrong tree, and hope to be able to finish the game once he provides a working version.

I’ve fixed the original bug that Zack encountered, but now he’s encountered another one (also due to a library change) that I’ve also fixed. I’ve just uploaded the latest version to I’ll hold off sending a new version to the IF-Archive for a few days to make sure Zack doesn’t encounter any more problems first!

If anyone else is halfway through Blighted Isle, you’ll need to use the corrected version of the game to complete it, but you won’t be able to use any saved game files from the old version. One workaround I can offer is to send a debug version on request to anyone who is in this situation. This version contains several debugging commands to let you teleport round the map, purloin any item, and various other things; with luck it would let you recreate the situation you had reached without having to start over again from the beginning. If anyone halfway through the game would like such a version, let me know.

I have to ask - how is it possible that I finished the game on my playthrough? I remember being horribly stuck in that part as well, but I forget the particulars. Out of curiosity, exactly WHAT is that bug? Has it always been present?

There were a couple of bugs introduced at some point when I issued a new version (probably intended to fix a few bugs - I forget the details since it was a while back) compiled against a new version of the adv3 Library which had introduced some changes that broke game code that previously worked. If you played an older version of Blighted Isle you may well have avoided these bugs, since they wouldn’t have existed in the original version of the game compiled with an earlier version of the library.

The relevant changes to the library were:

  1. The code that blocked taking an object of the Immovable class was moved from the action() to the check() stage. This meant that a couple of Immovables with overridden actionDobjForTake() methods no longer worked as they were meant to since attempting to take the objects in question was now ruled out at the check() stage.

  2. The handling of throwing objects from one room to another when the two rooms were connected by a DistanceConnector was changed so that throwing was blocked (or allowed) separately from moving. This meant that a puzzle involving throwing an object no longer worked as the throw which had previously been allowed was now blocked by the library.

More specifically:

[spoiler]1) It was made impossible to dismantle the cairn (which needed a command like TAKE CAIRN or TAKE ROCKS).

  1. It was made impossible to find the wooden stick you needed by searching through the bits of wood on the Heavily Wooded slope.

  2. It was made impossible to lower the drawbridge from the Enclosed Meadow by throwing something at the lever that controlled it.[/spoiler]

These problems have been fixed by the update.

I played version 2… ah well, it’ll remain a mystery. But thanks for clearing that up.