Beta Testers Needed for classic 80's mainframe text adventure

Even with a two-word parser, trying to spell out every combination of viable commands explicitly is quite error-prone. For example, you listed EXANIM instead of EXAMIN in your post. If you had EXAMIN coded in for three dozen nouns but accidentally put EXANIM for one of them, what are the odds you would spot that in testing?

I understand that this is meant to replicate an old-school experience, but surely keeping a list of nouns and a list of verbs separately would cut down your dictionary by several orders of magnitude? Even the Scott Adams games (also originating in the 70s) handled synonyms for verbs and nouns separately rather than coding in each combination of GET/GE/G TAKE/TAK/TA/T etc + KEYS/KEY/KE/K/KEYRING/KEYRIN/KEYRI/KEYR/RING/RIN/RI/R individually.

You might want to reach out to Jason Dyer in his blog, he is doing the “All Adventures” project where he plays every adventure that was ever made, in chronological order (All the Adventures | Renga in Blue). He’s still in 1982 (with this pesky huge Ferret game that was also apparently never solved) but if you have any evidence that this was available in 1978, I think he’ll be interested to know.

Otherwise, consider me a tester; I’ll pick it up starting tomorrow (of course, with the caveat that I have two kids and a full time job!)

1 Like

Yeah, that was my typo in the message, but such a typo doesn’t exist in the “dictionary”.
The “Dictionary” was created programmatically, no human was involved, so there were no mistakes.

But none of that matters - the game as it is, is 100% coded to replicate the gameplay of the original as it was, and as we played it. Only very slight variations on verbs/nouns are added, and only those that would make sense to a reasonable person in the situation it applies.

Seriously, the parser is exactly where I want it, it has a bit more than I like, but it’s a tad friendlier than the original code was in 1978. It’s meant to be a faithful recreation, and that’s exactly what it is.

I could really care less what Scott Adams or anyone else was doing, or what Zork or Adventure, or Rogue, or whatever could do. This ISN’T those games.

So the game is done as far as I’m concerned, it’s 100% exact to the original, with a few minor additions, but what I need is testers that will actually play the game, draw a real map, actually solve it,
No trying to twist the parser into contortions.

I will ignore any and all messages about the parser unless they are showstoppers, and even then, if it’s just something stupid to crash the game, I’ll ignore that too.

No one has ever actually tried to solve it, no one has ever made a map.
And that’s just pathetic.

I’ll drop him a line, appreciate that and any testing you can do of actual game play,
try to map it, try to solve it, watch out for show stoppers.
but please keep to the spirit of the original parser as it’s meant to be.
means no shortcuts for item names “KEYS” are “KEYS”.
It may be a ring of keys, but that doesn’t make it a ring.
and “GET” is “GET”
none of this “KE” or “GE” or “G” nonsense.

Those were not available in the original, so the game keeps to the original intent.
The parser may be stuck to the first 5 letters or so letters of the first two words,
and the parser may be rather unforgiving, but that’s how it was meant to be,
so that’s how it is.

That comment seems a little unfair to people like Canalboy, who obviously were testing it to solve it but were frustrated in their attempts with bugs in the program.

I know that Roger, from his review, his comments there and elsewhere, and his promotion of the game in other places was doing a lot of work on the game. He is a fan and an old hand with large, complex, mainframe adventures. The New Castle - Details

If you do put your game out for testing, you have to be open to feedback from testers otherwise they will get disillusioned with the whole process and not want to continue.

5 Likes

Every programmer I know just winced.

10 Likes

My spelling of “mis-steaks” didn’t survive these forums parsing.

(See what I did there) :slight_smile:

I don’t understand what you’re trying to achieve with these aggressive, disappointed messages. It sure doesn’t sound like a great strategy for fostering player enthusiasm.

10 Likes

I’m sorry you feel that way.

The parser is exactly the way it was originally meant to be,
it’s played exactly as it was back in the day as originally intended.

It’s a thing of beauty. I only care about show-stoppers that affect overall solvability.

I’d love to see someone try to make a map though, that’d be nice, for a change.

1 Like

I wonder whether there may be some kind of mismatch of expectations at work here. Your topic title claims that you are looking for beta testers. Now when I think of beta testing something, I’m thinking of an activity where I play a game, where I note down everything that seems suboptimal to me, and where the author is then going to use my feedback to improve the playing experience. So I just started up your game The New Castle, and if I were a beta testers I would tell you that:

  • ‘l’ is not recognised as a synonym of ‘look’, and generates two parser error messages where one should be enough.
  • ‘look’ prints the room description twice instead of once.
  • the opening locations don’t tell me which directions I can go in.
  • when I’m in the shack and I type ‘take all’, something really weird happens:

It seems like I go blind by lightning, but then I can still see and nothing seems to have changed? Very confusing. Also, the items have not been picked up.

Okay, here’s my hypothesis: you don’t care about any of that. You want to recreate the original game experience; this is the original game experience; you are satisfied. But this means that I have nothing to do as a beta tester. I suppose the only way anyone could test the game is by comparing it to the original mainframe version, but that doesn’t seem feasible.

So I’m wondering whether you’re really looking for testers. Aren’t you just looking for players? If so, perhaps it’s better to open a new topic where you announce your game and tell prospective players why they might be interested! What’s the historical interest of the game; what’s the gameplay interest of the game; and so on. You’d probably want to pitch it to a very specific audience, namely true retro adventure gamers. (As you may have seen from my attempt to ‘take all’, I’m not really part of that audience.) Juts my two cents; but asking for testers seems to generate a real mismatch between what you actually want and what people who see themselves as testers think you want. :slight_smile:

13 Likes

I’ve played a bit, and reached 142 out of 590 points.

A technical note:
I don’t know if I’m missing a setting, but at least on my system (Windows 8.1), the output doesn’t seem to be scrollable (back), and there is no paging function (like “more”/“press key to continue”); so when more text is displayed than fits at once on a terminal window, it simply jumps to the end; the beginning of the output immediately scrolls off screen at the top, and there’s no way to read that part of the output.

Of course, I can fiddle around with my terminal settings for size/rows/columns, but since some of the outputs (for example the quotes) are fairly long, I can’t know beforehand if it’s enough, so it would be preferable if the game were to handle that.

It doesn’t seem as if all variations are covered at the moment. Near the entrance to the castle:

A long vine hangs down from the tree.

Move…? ex vine

I don’t understand that.
[…]

Move…? exam vine

I don’t See Any vine Here…
[…]

Move…? examine vine

It is a Vine, perhaps you could get things “swinging”…
[…]

Some other remarks:

It’s not clear why the connection between the southern and the northern end of the cold hall is one-way.

Another non-reciprocal connection: from the top of a staircase, both WEST and DOWN lead to the Glorious Marble Room, but only EAST leads from the Marble Room to the staircase; UP doesn’t work.

You can go up from the top of the staircase; not clear how that works.

There are several rooms where the exits aren’t mentioned, so one has to try them out.

About the fireplace:

Move…? douse fire

Excellent idea, einstein! excellent… but wrong…

I don’t See Any WATER Here…

Move…? inv

You Are Carrying…
A Ring of Keys.
A Hammer.
A Bottle of Oil.
Some Food.
A Bucket.
Some Water in The Bucket.
A Silver Hatpin!
A Platinum Coat of Arms!
A Priceless Sculpture!
A Gold Coin!

Move…? use water

You put out the fire with the water.

I don’t See Any WATER Here…

The plank:
Not sure where/how to use it… I tried DROP PLANK, USE PLANK, CROSS GORGE, EAST at the gorge, and similarly at the snake pit, but it didn’t work. (But possibly I’m barking up the wrong tree entirely.)

The south door in the Giant Games Room:
The sign said “Drop Coin to Enter”, so I tried DROP COIN, USE COIN after I obtained the gold coin, but it didn’t work. I probably need more hints here.

Here’s a map of my progress so far:

Expand to show image:

Trizbort file:
castle_map.zip (2.7 KB)

6 Likes

Whoa, thanks for the “fire” solution. I was pulling my hair out for that one.
Have you managed to correctly light the candle and use it? When I LIGHT CANDLE the first time in the Marble room (with the fire still burning) I get an “ok” but the description doesn’t change, and when I go to the dark room I still can’t see anything. Subsequent LIGHT CANDLEs don’t work anymore.

1 Like

By the way, one major bug I found (I’d say definitely a show-stopper): Every time you drop something and pick it back up in the Old Shack you get new points (5 for normal items, 10 for treasures). I suspect it’s because, in other areas of the game, when you drop an item you lose those points, then you win them again when you pick them back up. But in the shack you’re supposed to drop items, so you don’t lose points by dropping (but still get points again when you pick them up).

2 Likes

Not yet, unfortunately.

I bumped my score to 184 and slightly revised the map:
castle_map_v2.zip (2.8 KB)

Regarding the wine storage: any ideas about the deadly passage north, or the dumb-waiter?

And about the maze? In the room before it, there’s something etched into the wall which can obviously be read backwards, but I don’t know how that helps, since I haven’t seen a sword anywhere.

1 Like

Wow! the first map I’ve seen so far! Thank you!

Judging by that map you’ve got done -maybe- 25%, maybe.

The etched thing isn’t actually backwards, guess that’s a hint,
but it plays a dual role, one which you’ve figured out - for later.
The other, non-backwards is also important for later.

Hint: it is possible to solve the entire game without needing to use the candle, if you’re careful.
Mostly planning, and maybe a tiny bit of luck.

You haven’t gotten past the gorge, but you’ve already seen the solution to that (not mentioned in this thread), now you just have to realize it.

Sometimes death is just death, this is the lesson of life. (sorry too philosophical)

the dumb-waiter there is a way to use them of course, took quite a while to figure that one out myself back in the day. I actually had to have someone tell me,
but as soon as they did I was like “oh, of course… duh”

I don’t know how to post those spoiler things (too new to this forum) so don’t know how to send you that command, I suppose I could do a PM.

I have a feeling that was borrowed from other game, a common thing, but not many use dumb-waiters.

Having said all that, I’d not focus on the dumb-waiters right now, it might cause more problems for you than you’re ready for.

You’ve got to get past the snake pit, and get across the gorge.

1 Like

Yeah I wouldn’t call that a show-stopper, doesn’t prevent winning the game.
Doesn’t affect winning at all. and I’m not too terribly concerned about the scoring.
I’m not going to worry about scores related to items/treasures in the shack.

the scoring isn’t even close to how the original game scored, it was an after-thought,
sort of “oops, I forgot to write down how this worked” so I put my own system in.

Totally non-critical. BTW getting a max score (or more) won’t win you the game.
winning the game has nothing to do with your overall score.
You don’t even have to collect any items or treasures (sorta, kinda) in order to win.
(sorta, kinda cuz you will need things in order to get to the end-game and win)

it’s not a score-based game, it never was.

that’s not good. I might look at that later.
the candle isn’t necessary if you’re careful, but it’s not good.
I’ll see what I can do about that.

the game is replete with one-way directions, it’s just a quirk of the game.

As for scrolling, nope, that’s why the game creates a log file of every session.
We didn’t have “scroll back” in the teletype-era, and this game emulates that.
as far as I know it’s a limitation of the fact it’s a DOS program in a DOS prompt.
I’m pretty sure the Linux and Mac versions are scrollable.
I doubt I can do anything to the DOS prompt to make that work though.
I don’t know if there’s something I can do in freepascal/DOS to allow this.
Friends don’t let friends use windows? (ha, sorry)

ah the water/bucket headaches rise from the ashes again. augh.
The extraneous “I don’t see any water here” is very weird.

DOUSE FIRE should work, if you have the bucket and water.
pref “POUR WATER” is the way it was meant to be.

I see you got past the fireplace, now go South :slight_smile:

DROP PLANK should have worked with the pit, although not with the gorge.
You still haven’t realized the solution to that, but you should have that by this point.
I’ll look into the snake pit for this, definitely a stopper here,
you need to be able to get past it - but not critical til much later

DROP COIN should 100% work, and I’ll have to look into that.
Although non-critical.

1 Like

You’re welcome! Mapping is fun. :slight_smile:

The function is indeed a bit hidden in the UI: You can mark the text with the mouse and click on the cogwheel icon in the upper right of the post editor window, and then on “Blur Spoiler”, or equivalently, you can enclose the text in these tags: [spoiler] ... [/spoiler].

Okay, fair enough. :slight_smile:

I just wanted to mention it in case it wasn’t intended that way.

The thing is that there are, on the one hand, some one-way connections which totally make sense (like the pit in the cobwebbed room; it’s expected to be one-way down), and on the other hand, there are one-way connections which don’t appear to have a clear reason for being one-way, such as this:

You are at the North end of a long, cold hall. There air here feels cool
and processed. Passages go to the North, East, and West.

Immediately, the player asks himself what kind of obstacle prevents him from going south, when he’s at the north end of a hall. Okay, we detour by going E, S, W, and thus arrive at the south end of the hall:

You are at the South end of a Long, Cold Hall. The air here feels cool and processed. Passages go N & E.

And when we go north, we are back at the north end, so there was no obstacle in the hall, after all:

Move…? N
You are at the North end of a long, cold hall. There air here feels cool
and processed. Passages go to the North, East, and West.

But okay, if it’s part of the recreation and the original vision of the game, I don’t necessarily want to dissuade you from it.

POUR WATER doesn’t work either, unfortunately.

Thanks for looking into the issues with the plank and the coin! :+1:

Using a newly patched version from yesterday (patch3_oct31_2022) where the plank now works, I managed to explore more of the map (see below) and increase my score.

Treasures I’ve found:

There is a Silver Hatpin Here!
There is a Platinum Coat of Arms Here!
There is a Priceless Sculpture Here!
There is a Fine Bottle of Wine Here!
There is a Hand-Crafted Candle Snuffer Here!
There are Some Rare Spices Here!
There is a Large UnCut Diamond Here!
There is a Fancy Gold Pocket Watch With Character Here!
There is a Famous Original Painting Here!
There is a Fine Piece of China Here!
There is The Original Pair of Levis Jeans Here!
There is a Golden Chain Here!
There is an UnRippable Golden Net Here!
There is a Priceless Statue Here!
There is a Golden Cross Here!
There is an Expensive Looking Pen Set Here!
There is a Pearl Necklace Here!

Current Inventory:

A Ring of Keys.
A Hammer.
A Bottle of Oil.
A Bucket.
A White Candle.
A Bar of Soap.
Some Brown Powder.
A Little Axe.

Score:

Score is: 326 Out of a Possible 590.

You Have Made: 435 Moves.
This Makes You a Explorer.

Expand to show map:

(The arrow-connections are one-way, the dot-connections require some special commands or puzzle-solving)

Trizbort map file:
castle_map_v3.zip (4.2 KB)