Best way to specify a plural thing

I had some crazy idea this would work to make plural things, but apparently not:

Lab is a room. 

The diamonds are in the lab.
The shelves are scenery in the lab.

The game prints a diamonds and assigns both things to the “it” pronoun.

Is the only way to fix this to use `They are plural-named"? I would have hoped for something a little more streamlined than that.

1 Like

Some diamonds are in the lab.

Should work!


See here for the full lowdown


There will probably be someone along any minute now to provide an exception I’m not thinking of, but I don’t think there are any cases where using a plural-conjugated vs. singular-conjugated verb in a sentence makes a difference. Inform is fine with: Color are a kind of value. Some colors is green.

I’m being deliberate in saying “verb in a sentence” there in reference to how these things are meant in WI 13.2: What sentences are made up from and Example 223: Formal syntax of sentences. Using the plural form is mandatory in constructing verb literals (the verb literal for “to be” is verb are) and in adaptive text (i.e., to say the verb).

Mostly, singular vs. plural declension of a noun doesn’t matter either. This ugliness compiles and outputs “duck!”:

duck are a kind of thing. There is 12 duck. The player carry 1 ducks.
when play begins, if the player enclose some ducks, say "duck!".

It does matter with kinds of value, though. If one has said some ducks is a kind of value. then one must say a duckss is hueya duck is huey would not compile. This disparity between kinds of thing and kinds of value possibly should count as a bug.

Other tricks:

some socks are in bedroom. The indefinite article is "a pair of".

But suppose we wanted something which there is an amount of, but which is not made up of individual items - a so-called mass noun like “water”, or “bread”. Now we can write:

The water is here. The indefinite article is "some".

and this time Inform does not treat the “some water” thing as a plural, so we might read:

You can see some water here.
The water is hardly portable.


Hehe… well, I have one that I know is real (at least in 6M62), and probably it’s just a bug, and it’s probably so arcane it’s of no relevance to the OP, and I can’t even demonstrate it with specifics right now. But here it is for Zed’s satisfaction or dissatisfaction.

It’s happened more than once in my WIP that I’ve created a plural-named thing, probably by saying stuff like ‘some yadas are a wearable thing.’ Then in the next sentence I’ve tried to apply some characteristic to it by saying ‘They are YADA.’ And in rare circumstances, that line has stopped the game compiling until I turned it to ‘It is YADA.’

Now I can’t tell you what characteristic it was because I’ve fixed each one I encountered at the time. So I don’t know if it was a kind, an adjective I made, a built-in-one, etc. This has happened about three times in 170k words of source. I also remember that the error message was slightly off-target in each case, meaning it took me a little while to find that what I’ve described was the problem.


1 Like

Nice, Wade, thanks. I looked into the singular/plural issue, with the same result as most of the time I dig into Inform’s behavior: I found anomalies and weirdness and bugs (or at least things I’d consider to be self-evident bugs). I7-2288: inconsistencies in the consequences of plural names in creation assertions of kinds of value and kinds of thing

[ Edited: That may be what happens most of the time… but some of the time I’ve made a fundamental mistake that cascades into an ongoing series of errors of interpretation, instead. And some of those times I say it out loud before I catch it and this was one of those. The real moral of the story is: Inform always takes your kind names to be singular, so you should really make them singular. If you make them plural, you’ll end up unable to refer to them in the singular. Unless we’re talking about deer, fish, or sheep. ]

Switches are a kind of thing.
The alarm button is in the Bank. It is a switch.

fails to compile in both 9.3/6M62 and v10.

It is a switches. works. But the relevant bit here is switches vs. switch – any of “it is”, “it are”, “they is”, “they are” would work. And despite all of that, either of There is a switch or A switch is in the Lab would work.

(I hadn’t tried it with a pronoun, but I feel pretty sure it’s the same issue as in the example I wrote in the bug that Children are a kind of thing. The Artful Dodger is a child. fails to compile.)

While we’re talking about under-documented grammatical number issues, the ambiguously plural property is used in one example, Olfactory Settings but never explained.

When the game updates pronouns from a singular-named noun, the meaning of “it” becomes that noun. When it updates pronouns from a plural-named noun, the meaning of “them” becomes that noun. When it updates pronouns from a singular-named ambiguously plural noun, the meanings of both “it” and “them” become that noun. Making a plural-named noun ambiguously-plural doesn’t change anything from the regular plural-named case.

1 Like

I’d actually been trying to figure out if there was a way to do this recently! Ambiguously plural, huh? Will need to remember that.

1 Like

Doesn’t this just make a thing called “switch” which is not a member of the “switches” kind?

1 Like

Doh! Yes. :person_facepalming:

Does it really work?

I just tried this in 6M62, where I’d previously made an adjective called ‘p-switchy’ to create objects that would do this. When I make the object ambiguously plural instead, ‘it’ is not being set to the object, only ‘them’.

EDIT: Oh wait, Zed said it has to be singular-named. My test object ‘pants’ is plural-named. When I made it singular-named, it worked. So… I’m not sure this is what I want, since I want it to say ‘some pants’, not ‘a pants’. I could change the indefinite article I suppose, but now I’ve done two things when I could just do one by making it p-switchy.


1 Like