Anno 1700

ifcomp2018-game
#1

I can’t get the blorb to run with Glulxe. Anyone else having this problem?

0 Likes

(Finn Rosenløv) #2

I have tried running the blorb on my computer and it works fine…
I’m looking into the problem, but would be grateful for any help…

0 Likes

#3

This is an ADRIFT 5 game. You need to use the ADRIFT runner from http://www.adrift.co/download.
There are two versions of the runner, one for windows and one for Linux with Mono (Which might also work on Mono for Mac but nobody with a Mac seems to have tried it yet)

0 Likes

(Petter Sjölund) #4

I tried it on a Mac without success. See this thread.

0 Likes

#5

I downloaded the ADRIFT runner. It won’t run the game, saying that it’s not a .taf file. Well, of course it’s not, it’s a .blorb file! :laughing: Any other suggestions? I’m wondering why it’s being called a .blorb file if it won’t run on Glulxe. Do I need a new version of Glulxe perhaps?

0 Likes

#6

I just tried it using Gargoyle (universal interpreter which can run Adrift games), both as the .blorb and renaming it with .taf. In neither case would it run.
EDIT: Just to see, I tried running it on my Android tablet in Fabularium, which is based on Gargoyle, and it worked fine there. The .glorb file, that is. No problems. Weird.

0 Likes

(Hanon Ondricek) #7

In my brief foray experimenting with Adrift, it seemed like there was a website you could go to and insert the path of an Adrift game hosted online to run it in the browser?

play.adrift.org.uk/?game=URL
(replacing URL with the address of the game)

Dunno if that’s helpful.

0 Likes

#8

A .blorb file is a container format that can have ANY interactive fiction format inside of it (along with pictures and sound files).
Unfortunately Gargoyle and Glulxe currently only support a few of these formats.
Gargoyle runs very OLD ADRIFT games, it does not run ADRIFT 5 games! However Fabularium has been updated for ADRIFT 5 (I don’t know how well it works, but make sure you have at least version 1.4.0)

Here are step-by-step installation instructions for ADRIFT 5 on a windows PC:

  1. Go to http://www.adrift.co/download
  2. Download ADRIFT5Setup.zip
  3. Unzip, which should produce a single file called Setup.exe
  4. Run Setup.exe to install ADRIFT 5.0
  5. The interpreter is called Run500.exe, run it and open the BLORB file from its file menu.
  6. If it doesn’t work your computer may be missing v4 of the NET framework (see http://wiki.adrift.co/General_Setup for more info)

The Linux Mono version is called adrift-5.0.35.tar.gz and is on the same download page.

0 Likes

#9

Sounds like you downloaded the ADRIFT 4 runner. ADRIFT 4 Runner doesn’t run ADRIFT-blorbs. ADRIFT-Blorbs were first possible with ADRIFT 5, so you need to install ADRIFT 5 to play the game. Unlike ADRIFT 4, the download file for ADRIFT 5 contains both a runner and a developer.

0 Likes

#10

Yeah, I initially tried installing ADRIFT 5 and got that message. I’ll try that. Thank you everyone for all the help!

0 Likes

(Finn Rosenløv) #11

I’m so sorry for the inconvenience, guys.
I promise that if I ever see Campbell I’ll whip his butt with a wet newspaper…

Hope you’ll enjoy the game despite all the hassle…

0 Likes

(Finn Rosenløv) #12

I’ve just uploaded a new version of Anno 1700.
A few minor typos has been fixed, plus a wrong description on a dark location.

P.s.
If you haven’t already found out, Campbell has uploaded a “stand alone runner” for playing Adrift V.5 games.
Download it and run it and you’ll be all set for playing Adrift V.5 games.

0 Likes

#13

Played through this game; the game as a whole felt undirected and seemed to go more for length than depth.

[spoiler]There were a number of places where commands were dependent on the noun phrase used. For example “UNLOCK DOOR” gives a message that it isn’t locked; “UNLOCK DOOR 101” works. “GET CANDLEHOLDER” triggers a side effect. “GET IT” (when “it” refers to the candleholder) does not. (Cause: The game uses General Tasks when it should be using Specific Tasks.)

My initial attempts to interact with my new employer stumbled. “TALK TO WOMAN” was not implemented. “ASK WOMAN ABOUT KEY” said she gave me a key, but didn’t. “ASK WOMAN ABOUT JOB” gave a message that she didn’t understand me. “ASK WOMAN ABOUT HOTEL” said I should drop my luggage first. Dropping my luggage there didn’t work; trying to go to my room gave the message that I should announce my arrival. At this point, I went to the walkthrough and found that I needed to “SAY HELLO TO WOMAN” first.

There is also a significant amount of random searching of scenery.[/spoiler]

0 Likes

(Finn Rosenløv) #14

Hi
Thanks for playing the game.
I’ve sent you a pm in the Adrift forum answering some of your comments.

0 Likes

#15

The beginning gives a brief background for this ADRIFT game: I’m a young woman trying to find myself, basically: interest in history, college sabbatical, going to my new job as a receptionist at an old hotel in Mexico, in a gulf where pirates once roamed.

I arrive. I talk to my boss, get my room key. I change clothes in my room. Then my boss tells me to just, look around, make sure the guests are happy.

And I go around, and try talking to guests, who all don’t respond much. Greeted the cook, tried greeting the maid, no other staff around. There’s a framed newspaper article in the lobby, says this place used to be a brothel run by the current owner’s great grandmother. I ask my boss about it, she tells me about secret tower that was closed off.

And that’s about as far as got before I had to check the walkthrough, and from then on that was what I was basically following. Later on, there’s some get some secret passages, lots of hidden objects and masked levers, with some guess-the-verb issues, like

put key in =/= insert key in
push/pull thing =/= turn thing

I stopped when the key I was using unceremoniously broke, and I looked at the walkthrough and it said that I just had to exit the room and go back, and I just had no clue where it might want me to go next. I didn’t want to just follow a walkthrough step by step.

So the beginning is just straight prose. Bit boilerplate, some slightly unnatural phrasing, but it’s fine, establishes a character. Then the game starts, and you turn back into Generic IF Adventuring Protagonist, and none of your character background really comes up.

I don’t know if other people play this way, but if I’m told I’m a receptionist, I’m going to do my darn job, especially after the sincere slice-of-life intro. I’m not going to start poking around at trees, picking stuff up, or even wandering around the hotel; I looked for my boss, I did what she told me to do, then I tried to look around for guests to help. And there weren’t any.Would it have helped if a guest had told me there was a squirrel problem, or something? Maybe.

I just think this feels too undirected. I’d love if the protagonist imposed themselves a bit more, expressing interest in the newspaper article, showing surprise at the secret passage, and in general directing some motivations for me to follow. But if it isn’t supposed to be that sort of game, it might still help if the description told me the candle holder looked suspicious, or the statue’s hands look like they rotate. Things happen, things “rise”, without really suggesting what action I might take next, and even important objects don’t suggest what I might do with them.

If those things were fixed, and if more verbs were implemented for puzzle objects, I think the puzzle aspects of this would be fine. I think they’d work well to generate a sense of mystery, of delving into a secret/hidden past. The history and geography of the place is intriguing and decently established, and I really liked the setting. The backstory-focused descriptions were good; it’s just the ones for interactable objects that were unhelpful, and generally it was just too hard to figure out what the game wanted me to do. (Also, it seems like this has been updated since I downloaded and played it, so some of this might be out-of-date!)

0 Likes

#16

I’ve also posted a review of the game on my blog.

0 Likes