Anchorhead: "with a venomous violet light." bug

So in day two, I went through the narrow corridors to get to the telescope room. I went in, dropped the disk into the telescope, then exited the room to the crawl space. Whenever I try to go east out of the crawlspace, it gives me the message “with a venomous violet light.” I’ve tried using every variation of “go east” that I can think of. I’ve gone in every single direction (being told I couldn’t go that way), then tried going east again, only to get the exact same message. I decided to go back to a previous save and just skip the telescope room until the third day.

On the third day, I follow Michael around the house, then go into the narrow corridor and watch him do his crazy stuff. After he leaves, I go to the telescope room, inspect the charts, drop the disk in the telescope, look through the telescope, then leave. When I try to exit the crawlspace, it gives me that same message again: “with a venomous violet light.

I don’t know how to get around this. This is the third time I’ve tried playing through this game, the first couple times because I didn’t pick up the towel, then because I missed an important plot point. I don’t want to have to restart the game from scratch. That would make the game a lot less fun, especially since I already have detailed notes and maps and have read all he dialogs three+ times.

Does anyone know how to get around this bug? Or does anyone know if there’s a chunk of code I can edit to get around this? Put myself in the next room so I can get on with the game?

Are you aware of the IFDB site? If you search for Anchorhead there, you will find a map & a solution.

I’ve already downloaded the map and the walk-through. The problem is not that I’ve reached a puzzle I can’t solve: the problem is that I have run into a software bug that will not allow me to progress further. I am literally trapped in an exit-less room.

I’ve searched the internet pretty thoroughly for a solution to this bug, so I figured I would ask here in case anyone else had run into the same bug. Or, if no one else has encountered this bug or can’t remember how to resolve it, I’ll just poke around in my save code to see if I can change my location to the next room over.

I don’t remember ever hearing of this bug, and Anchorhead has been around for a long time; in fact when you first mentioned it, my thought was, “huh, I wonder if there’s actually something wrong the interpreter kinzkey is using”. But I could be wrong. That does sound really frustrating, in any case.

That’s an interesting possibility we can’t rule out. kinzkey, which interpreter are you using?

I have seen strange gameplay effects with Filfre (Jigsaw) and ZaxMidlet (Deadline), so I know it’s possible.