[6G60] Inform 7 and Natty (Ubuntu 11.04).

As of Beta 1, at least, none of the .deb packages will install under Natty Newt due to the required version of libwebkit no longer existing.

Perhaps you can just make a symbolic link from the old version of libwebkit to the new version? I’m still on 10.10, so I haven’t tried this, but I used it for another library a while ago: gamingphilosopher.blogspot.com/2 … u-904.html

No dice. And compiling from source gives this on running it:

Well, this may be because of new GLib… I think they went with Gnome 3’s GLib in Natty. Also, try reporting it as a bug to GInform devs.

I can confirm that Gnome Inform7 is unrunnable on Ubuntu 11.04 (64). I get the same message when compiling:

snowdrop@air:~$ gnome-inform7

code: GtkSourceView-CRITICAL **: gtk_source_style_scheme_manager_get_scheme: assertion `scheme_id != NULL’ failed

(gnome-inform7:13263): GConf-CRITICAL **: gconf_engine_set: assertion `value != NULL’ failed

(gnome-inform7:13263): GConf-CRITICAL **: gconf_value_get_string: assertion `value != NULL’ failed

(gnome-inform7:13263): Gtk-CRITICAL **: IA__gtk_font_button_set_font_name: assertion `fontname != NULL’ failed

(gnome-inform7:13263): GLib-CRITICAL **: g_ascii_strcasecmp: assertion `s2 != NULL’ failed

(gnome-inform7:13263): GLib-CRITICAL **: g_ascii_strcasecmp: assertion `s2 != NULL’ failed

(gnome-inform7:13263): GLib-CRITICAL **: g_ascii_strcasecmp: assertion `s2 != NULL’ failed

(gnome-inform7:13263): GConf-CRITICAL **: gconf_value_get_string: assertion `value != NULL’ failed
Segmenteringsfel
snowdrop@air:~$
[/code]

Did someone report this or is it still unreported?

Someone reported it: 651.

Glad I haven’t upgraded! I may never upgrade on this machine, after seeing the changelog for 11.04

I guess this may mean that the next version of Inform7 for Gnome will be Natty Narwhal -only? Oh, no… :imp:

So… Are they going to split it up and release pre-Natty and post-Natty separately, recode conflicting stuff to suit both systems, or should I break out my C++ IDE and try to make a little rewrite myself? I can think of few changes that may be useful, like Scintilla instead of GTKSourceView and Gecko instead of Webkit… :nerd:

After discussing it with the developer the following was brought into the light:

  1. The problem is known, as suggested above. A solution is to just do the “make install” again (that worked for me). The end result is however somewhat unstable or me, but works well most of the time.

  2. A .deb for 11.04 is on it’s way and should already be released at the projects sourceforge page. Last time I tried it though it refused to install on my 11.04

As of yesterday gnome-inform7 has been repackaged for the 64-bit version of Ubuntu 11.04, and that package is available from inform7.com. (I built it myself as soon as I upgraded to 11.04, and I am testing it on my own system, where it has been working just fine.) [rant]By the way, am I the only person who can’t get Unity to run at all? It’s not even defaulting to Gnome 2, it’s just leaving me with the default Ubuntu wallpaper and a cursor that can’t do anything, though I can hear Skype starting. The Ubuntu forums have been of no help so far. It’s probably my stupid Radeon videocard…[/rant] I imagine a new i386 package will follow shortly.

And it has.

What display manager are you using? gdm or kdm? I couldn’t get Unity running on my netbook until I disabled kdm.
[rant]Unity is still a rushed product IMO. It barely works on netbooks - the intended target, and various chipset/video card combinations have too great effect on it. Also, on my netbook, whenever I click on anything in Qt, X server crashes. Anyone else gets that?[/rant]

Thanks for the advice, but I don’t even have kdm installed. And now I’ve totally derailed this thread. Sorry, folks.

Hmm… now the Ubuntu 10.10 downloads have been removed from the 6G60 downloads section. Good thing I already have it installed. Why remove a perfectly good distribution just because a newer version of Ubuntu is available?

The 6G60 versions for Ubuntu 10.10 are still available on the project page:

sourceforge.net/projects/gnome-i … orm7/6G60/

Ah, didn’t look there. Thanks!